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Using Waypoints with ProMark3 and MobileMapper Pro 
13 November 2006 
 
Note: These instructions describe the latest versions of MobileMapper Pro and ProMark3 
receiver firmware and the latest version of MobileMapper Office. You may download the 
latest versions at no charge from the following folders on ftp.magellangps.com: 

a. MobileMapper Pro firmware:  \Mobile Mapping\MM Pro\Firmware 
b. ProMark3 firmware:   \Land Survey\PM3\Firmware 
c. MobileMapper Office:  \Mobile Mapping\MM Office\Software 

 
How do I create waypoint files in MobileMapper Office for 
uploading to the ProMark3 and MobileMapper Pro receivers? 
Click on Options>Select Coordinate System and either select a previously used 
coordinate system or create a new one to match the coordinate system of the waypoints 
you wish to input into MobileMapper Office. Click on Tools > Place Waypoints or on 
the Place Waypoints icon (a push pin) in the main tool bar. This launches the Waypoints 
window to the right of the map screen. You may select from a variety of map symbols to 
identify the waypoints. You may also use the box under the symbols to name the 
waypoint that you wish to place on the map. Then click on the location on the map screen 
where you wish to place the first waypoint. To see more precisely where the arrow cursor 
is located, you may refer to the coordinates’ box to the lower right of the map screen. The 
level of precision here corresponds to the level of precision with which you can move the 
cursor. Once a waypoint is place a waypoint on the map screen, you can adjust its 
location with greater precision by editing its coordinates on the Waypoints window.  
 
The coordinates’ box (to the lower right of the map screen) 
only displays the coordinates of the arrow cursor when I’m in 
latitude/longitude. How do I display coordinates when using a 
grid system? 
You probably have not selected the correct zone for your grid system. Click on Options 
> Coordinate System and reselect the zone. If you do not know the zone, select the 
Geodetic, WGS84 option instead of the grid, position the arrow cursor in the center of 
your positions (features or waypoints) and make a note of the longitude. Then go back to 
Options > Coordinate System, reselect the grid system you want and select the zone 
based on the longitude in degrees that you just wrote down. To determine which state 
plane coordinate system zone you are in, please refer to http://www.ngs.noaa.gov/cgi-
bin/spc_zones.prl. 
 
I did not use the default name (WPT001) for the first waypoint, 
but when I add more waypoints each is automatically given the 
default name. Is there any way to automatically increment 
non-default waypoint names? 
Because you are free to use all six characters to name your waypoints, the automatic 
incrementing of the waypoint names works only for the default waypoint name where the 
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first three characters are always “WPT” and the subsequent characters are numerals 
beginning with “001.” 
 
How do I edit waypoint files in MobileMapper Office? 
If you want to edit the parameters for your waypoints, we recommend that you first place 
the arrow cursor on the boundary between the map window and the waypoint window. 
Click and drag this boundary to the left so as to enlarge the waypoint window to reveal 
all the parameter fields that you may edit. To edit any parameter for any waypoint, 
double-click on the field and type in a new value. These parameters include: 

- Display/hide waypoint 
- Waypoint name 
- Latitude (northing) 
- Longitude (easting) 
- Altitude 
- Icon (map symbol) 
- Message 

You will notice that there is increased level of precision when editing a waypoint’s 
position: one one-thousandths of a minute or one tenth of a meter/foot. 
 
How do I build routes in MobileMapper Office? 
Once you have positioned some waypoints you may link them together to form routes. 
Click on Tools > Build Routes or click on the Build Routes icon next to the Place 
Waypoints’ push pin icon. (The Build Routes icon represents three waypoints connected 
with straight lines.)  Then use the arrow cursor to click on the waypoints in the desired 
order in which you want to build the route. 
 
How do I save my waypoint files in MobileMapper Office? 
All waypoint and route files must be associated with a MobileMapper job file (*.mmj). 
So, you first must save the waypoints to a job by clicking on File > Save As. When you 
select a job name, two files are actually created by MobileMapper Office: the job file 
(filename.mmj) and a separate waypoint file (filename.mmw). You do NOT have to 
import any features into the job file for the waypoint file to be generated. 
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How do I import waypoint files into MobileMapper Office for 
upload to the receiver? 
In order to import a waypoint file into MobileMapper Office it must be in the same 
format as MobileMapper waypoint files or specially formatted .txt or .xls file. There is no 
conversion module to automate the importing of files in other formats.  
 
A. Importing a .txt file 
In order to import a txt waypoint file in .txt format, the file must contain the following 
information:  

1. A command line: “$PMGNWPL” 
2. A numeric field is the latitude in DDMM.MMMMM (Degrees.Minutes.Decimal 

Minutes to 5 places) 
3. An N (or S) for north (or south) latitude 
4. A second numeric field for the longitude in DDDMM.MMMMM format 

(Degrees/Minutes/Decimal Minutes to 5 places) 
5. An E (or W) for east (west) longitude 
6. A third numeric field (in the example below, a zero) for the altitude 
7. A field for a message (indicated in the example below by the letter “M” 
8. A field containing the waypoint’s name, in this case WPT001 
9. A final field containing a code for selecting an icon 

 
After importing a waypoint file into MobileMapper Office, you can edit waypoint names, 
icons and messages as desired. 
 
Example of a waypoint file in .txt format 
$PMGNWPL,3721.08731,N,12156.18597,W,0,M,WPT001,,a*2D 
$PMGNWPL,3721.12816,N,12156.15346,W,0,M,WPT002,,a*28 
$PMGNWPL,3721.09022,N,12156.07005,W,0,M,WPT003,,a*2B 
$PMGNWPL,3721.03921,N,12156.09323,W,0,M,WPT004,,a*25 
 
B. Importing a .xls file 
It is also possible to import waypoints contained in Microsoft Excel files if the format is 
correct. The following is an example of what information must be in each column. Note: 
the first row of column headers is mandatory. 
 
 

# Name Icon Message Latitude Longitude Altitude
(m) 

Latitude 
(degrees) 

Longitude 
(degrees) 

Icon ID

1WPT001 Crossed Square   N37°21.087' W121°56.186' 0 37.35145517 -121.93643283a 
2WPT002 Crossed Square   N37°21.128' W121°56.153' 0 37.35213600 -121.93589100a 
3WPT003 Crossed Square   N37°21.090' W121°56.070' 0 37.35150367 -121.93450083a 
4WPT004 Crossed Square   N37°21.039' W121°56.093' 0 37.35065350 -121.93488717a 
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How do I upload waypoint files into the MobileMapper Pro and 
ProMark3 receivers? 
Once you have created a job that has waypoint and route files associated with it, you 
upload the job to the receiver the waypoint files are automatically uploaded with the job. 
When you open the job file in the field, the receiver automatically displays the waypoints. 
You can also open the waypoint files without opening the job by pressing the Menu 
button and selecting GOTO > User Waypoint > Positions. Select the waypoint you want 
to navigate to and press the Enter button. You may use any of the MobileMapper 
navigation screens to find the selected waypoint. 
To select a route, press the Menu button and select the Routes option. You then select the 
specific route you want to use, press enter and select the waypoint where you wish to 
begin using the route. 
 
How do I display waypoints in the receiver? 
There are two ways to do this: 

1. Press the MENU button and select the Card Utilities option and then the Load 
WP/Route option. 

2. Press MENU and select the Setup option and then the Map Display option. Press 
the right arrow button to move to the Display tab. Scroll down to the Mark All 
option or the Waypoints option and press ENTER. Then press ESC to accept the 
changes and move back to the Setup screen. 

 
How do I hide waypoint files in the receiver? 
Press MENU and select the Setup option and then the Map Display option. Press the 
right arrow button to move to the Display tab. Scroll down to the Clear All option or the 
Waypoints option and press ENTER. Then press ESC to accept the changes and move 
back to the Setup screen. 
 
How do I delete waypoint files from the receiver? 
You can do this in three ways: 

1. When downloading files using the MobileMapper Transfer Utility, click any file 
you wish to delete and click the Delete button on your keyboard or on the 
Utility’s tool bar. You can also right-click on any file and select the Delete option. 

2. With the SD card in a card reader, use Windows Explore to delete any file on the 
receiver. 

3. Formatting an SD card will delete all the files on the card. Magellan recommends 
that you reformat your SD card before every project, or more often, if you wish. 

a. If you have a MobileMapper Pro, press MENU, select the Card Utilities 
option and then the Format Card option. 

b. If you have a ProMark3, put the card in a card reader attached to your PC. 
Use Windows Explore to right-click to the card’s drive and select the 
Format option.  
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How do I edit waypoint descriptions in the receiver? 
With the waypoint file selected for display, press the NAV button until you come to the 
Map screen. Then use the arrow button to move the map cursor over a waypoint symbol 
and press ENTER. If the name of the waypoint you have selected is correct, press 
ENTER a second time. You will now see a screen with the Edit option highlighted. 
Press ENTER again and you will see the Edit Waypoint screen. Use the arrow button to 
move to the field you wish to edit and press ENTER. 
 
How to do I create waypoints in the MobileMapper Pro 
receiver? 
Either press the LOG button for > 2 seconds or press MENU and select the Mark 
option. 
 
How to do I create waypoints in the ProMark3 receiver? 
You can create waypoints when running both the Surveying and Mobile Mapping 
applications by pressing the MENU button and selecting the Mark option. However, if 
you wish to download the waypoints in a file to your PC, you open a job in the Mobile 
Mapping applications while the waypoints are displayed on the map screen and then save 
the job to memory. When you download the job file (with a .mmj file extension) using 
MobileMapper Office, the associated waypoint file will also be downloadable. 
 
How do I download waypoint files from the MobileMapper Pro 
receiver to MobileMapper Office? 
1. Attach the receiver to the PC using the serial data cable 
2. Turn the receiver on 
3. In MobileMapper Office, do either of the following: 

a. Click File>Download Waypoints/Routes 
b. Click File>Download from GPS 

You may alternatively place the receiver’s SD card in a card reader and, in 
MobileMapper Office, click File>Download Waypoints/Routes and navigate to the drive 
representing the card reader. 
 
How do I download waypoint files from the ProMark3 receiver 
to MobileMapper Office? 
1. Attach the I/O module to the back of the receiver 
2. Attach the I/O module to your PC using the USB download cable. (A DB9-female to 

DB9-female serial data cable may also be connected to the I/O module’s DB9-male 
(COM 1) port and a COM port on the PC.) 

3. Turn the receiver on and run either the Surveying or Mobile Mapping application 
4. In MobileMapper Office, do either of the following: 

a. Click File>Download Waypoints/Routes 
b. Click File>Download from GPS 

You may alternatively place the receiver’s SD card in a card reader and, in 
MobileMapper Office, click File>Download Waypoints/Routes and navigate to the drive 
representing the card reader. 
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Can I use MobileMapper Office to edit waypoint files recorded 
in the field? 
Yes. The process is the same as when you use MobileMapper Office to create waypoint 
files. 
 
Can I export waypoints out of MobileMapper Office? 
Not with the present version. A workaround is to use the MobileMapper Pro and 
ProMark3 receivers to collect point features instead of waypoints. Point features can be 
much more conveniently described using feature libraries instead of the 30-character text 
field that is available for waypoints. Also, point features can be easily exported in GIS 
formats using MobileMapper Office. 


